Szavazás Juniper szekcióról

Érdekesek a Juniper howto-k?

Szavazás Mondeo átépítésről

Mondeo átépítés

CISCO router VLAN trunk

CISCO router VLAN trunk

PDFPrint

Volt egy kis hálózatépítés, ami egy Cisco CCNA vizsgának is megfelelne akár. Mivel kb. 6 órát szenvedtem a problémával (lévén, nem vagyok még Cisco expert), gondoltam, itt közzéteszem a megoldást, hátha valakinek szüksége lesz rá.

A meglévő hálózat VLAN trunk-be konfigurált 5 db Cisco Catalyst switch-ből állt. Az 5 switch egy Cisco 1841-es routeren keresztül kapcsolódott internetre. A rendszerben sok VLAN volt, ebből kettőt NAT-olt ki a router az internetre, valamint biztosított nekik DHCP szolgáltatást. 

A router config:

 !
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname BKK_20M
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.32.240 192.168.32.254
ip dhcp excluded-address 192.168.31.240 192.168.31.254
!
ip dhcp pool BKK
   network 192.168.28.0 255.255.252.0
   default-router 192.168.31.254
   dns-server 84.2.44.1 84.2.46.1
   domain-name bkk.hu
   lease 8
   update arp
!
ip dhcp pool BKK_22
   network 192.168.32.0 255.255.255.0
   default-router 192.168.32.254
   dns-server 84.2.44.1 84.2.46.1
   domain-name bkk.hu
   lease 8
   update arp
!
ip dhcp pool Nestle
   host 192.168.28.19 255.255.252.0
   hardware-address 0015.c5b1.bf48
   client-name Nestle
!
!
ip domain name bkk.hu
!
crypto pki trustpoint TP-self-signed-2707480325
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2707480325
 revocation-check none
 rsakeypair TP-self-signed-2707480325
!
!
crypto pki certificate chain TP-self-signed-2707480325
 certificate self-signed 01
  30820246 308201AF A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32373037 34383033 3235301E 170D3039 30353239 30383436
  32355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 37303734
  38303332 3530819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B16D F5A71F63 45F39444 565806FC 43E4D8C4 8FE6AD5B C6EB486D 2755BAF9
  3344F6C4 1E74E264 19ACD96D 60C4A6F8 A0918885 2ADD45CA CD7FEDBE 51111FB8
  1FB74B2A F1DD2F5E C790B323 75F53DA5 EF495A19 6FDA11FE 28DAB39C A8985888
  D765894B CEBECD70 B15B204C E14E3717 8123A245 68393503 A0187978 C2C05D0B
  EC210203 010001A3 6E306C30 0F060355 1D130101 FF040530 030101FF 30190603
  551D1104 12301082 0E424B4B 5F32304D 2E626B6B 2E687530 1F060355 1D230418
  30168014 41CE5C92 2D769479 89E1D703 13F01782 30B7AA92 301D0603 551D0E04
  16041441 CE5C922D 76947989 E1D70313 F0178230 B7AA9230 0D06092A 864886F7
  0D010104 05000381 81005220 8E5BB5CB 1C76750F E6F3975E BF7D5E78 56DA27AA
  7C9050CF 6D4C5045 1A263444 CB16A443 6E560CC7 FC488C0E B6E60B82 59B28F31
  7DAB40FF 7CC01C43 D96093DE 70667A7C 566ECD24 D5F19E09 7C66ECDB D0304BAB
  4FE44F9C CDF8C094 FDE7E96F 59768731 8EDB9EE3 7106C14A 70BD224F B939A2E2
  71BCE7DD FEDE7939 CD1E
  quit
username admin privilege 15 secret 5 $1$yfmx$2TYzZCdHmZvWxgOaxU/Tm/
!
!
!
interface FastEthernet0/0
 ip address 192.168.10.210 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1462
 ip nat inside
 ip tcp adjust-mss 1400
 no ip mroute-cache
 duplex auto
 speed auto
 no snmp trap link-status
 no cdp enable
!
interface FastEthernet0/0.22
 encapsulation dot1Q 22
 ip address 192.168.31.254 255.255.252.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1462
 ip nat inside
 ip tcp adjust-mss 1400
 no ip mroute-cache
 no snmp trap link-status
 no cdp enable
!
interface FastEthernet0/0.23
 encapsulation dot1Q 23
 ip address 192.168.32.254 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip mtu 1462
 ip nat inside
 ip tcp adjust-mss 1400
 no ip mroute-cache
 no snmp trap link-status
 no cdp enable
!
interface FastEthernet0/1
 ip address 84.1.95.54 255.255.255.252
 ip nat outside
 duplex auto
 speed auto
 no cdp enable
!
ip route 0.0.0.0 0.0.0.0 84.1.95.53
ip route 192.168.20.0 255.255.255.0 192.168.10.1
!
!
no ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 100 interface FastEthernet0/1 overload
!
access-list 100 permit ip 192.168.0.0 0.0.255.255 any
no cdp run
!
!
!
control-plane
!
!
!
line con 0
 login local
line aux 0
line vty 0 4
 access-class 1 in
 privilege level 15
 login local
 transport input telnet ssh
line vty 5 15
 access-class 1 in
 privilege level 15
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
end

A switch konfigot mindenki el tudja képzelni :)